Horde3D

Next-Generation Graphics Engine
It is currently 21.04.2019, 19:40

All times are UTC + 1 hour




Post new topic Reply to topic  [ 17 posts ]  Go to page Previous  1, 2
Author Message
PostPosted: 10.12.2016, 22:02 
Offline

Joined: 17.11.2009, 17:00
Posts: 175
Location: Russia, Moscow
It seems that with forward pipeline alpha channel is modified during rendering (it is not 1), and that is why you see it as transparent after you add the texture to the scene. You should probably add another shader that sets alpha to 1 and create new pipeline with this new post-processing step, or modify existing shaders.
As for deferred - are you using deferred pipeline for both cameras or only for the first one? Maybe there is a collision somewhere in the engine - if you use the same pipeline for both cameras, maybe GBUFFER is not cleared. I do not know the cause, I can only guess.

You can try to profile/debug your graphics with GPUPerfStudio (for AMD cards) or NSight (Nvidia cards). These tools will show you the internal state of OpenGL during rendering steps and will probably help you with finding the cause.

Please post your code here, I'll try to debug it too.


Top
 Profile  
Reply with quote  
PostPosted: 13.12.2016, 09:37 
Offline

Joined: 02.12.2016, 12:30
Posts: 23
yep!
You are right..
it's the problem with the pipeline, if i use same pipeline for both camera then it shake up each other, but it's different for HDR pipeline..
here i use HDR pipeline for both camera...


Attachments:
File comment: RTT using hdr pipeline
zzhdr.jpg
zzhdr.jpg [ 155.97 KiB | Viewed 1243 times ]

_________________
~@AlmahmudRony@~
Top
 Profile  
Reply with quote  
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 17 posts ]  Go to page Previous  1, 2

All times are UTC + 1 hour


Who is online

Users browsing this forum: No registered users and 3 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Group