Horde3D

Next-Generation Graphics Engine
It is currently 20.10.2019, 23:26

All times are UTC + 1 hour




Post new topic Reply to topic  [ 4 posts ] 
Author Message
PostPosted: 27.04.2011, 21:35 
Offline

Joined: 11.09.2010, 20:21
Posts: 44
Location: Germany
This is not really a bug, but the check for NPOT texture support in RenderDevice::init() and Renderer::init() is not neccessary, as OpenGL 2.0 is required anyway and this brings NPOT textures to core.


Top
 Profile  
Reply with quote  
PostPosted: 28.04.2011, 07:17 
Offline

Joined: 08.11.2006, 03:10
Posts: 384
Location: Australia
I'm not quite sure, but I think there might have been some laptop cards that reported supporting GL2.0, but actually did not support NPOT textures... :(


Top
 Profile  
Reply with quote  
PostPosted: 28.04.2011, 08:36 
Offline
Tool Developer

Joined: 13.11.2007, 11:07
Posts: 1149
Location: Germany
I also think that we got some ATI cards that didn't support NPOT but otherwise are running Horde3D quite well. And if we want to create some ES port we can't count on NPOT support too.


Top
 Profile  
Reply with quote  
PostPosted: 28.04.2011, 13:24 
Offline

Joined: 11.09.2010, 20:21
Posts: 44
Location: Germany
Ok, I didn't know that. I thought, that if you support GL 2.0, you really support GL 2.0 and not just a subset of it, but with ATI you can never be sure.


Top
 Profile  
Reply with quote  
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 4 posts ] 

All times are UTC + 1 hour


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Group