Horde3D

Next-Generation Graphics Engine
It is currently 22.07.2018, 17:48

All times are UTC + 1 hour




Post new topic Reply to topic  [ 1 post ] 
Author Message
PostPosted: 06.12.2011, 02:28 
Offline

Joined: 05.12.2011, 11:32
Posts: 4
Hi all,

I'm quite new to Horde3D, so I'm not sure if this is a known / expected behavior or not...

In the Knight example (and I assume in the Chicago example and most other applications), I've found that the view matrix is always the Identity transform for the first 3 frames. It's set properly for the 4th and subsequent frames. This seems to have something to do with _relTrans vs _absTrans. _relTrans gets set immediately when h3dSetNodeTransform( _cam, ...) is called and the node is marked "Dirty", but the renderer uses _absTrans to set the view matrix, and it remains (0,0,0) for the first 3 frames. Before the 4th frame, SceneNode::update() is called on the camera node and _absTrans is set properly.

Just thought I'd see if anyone knows what's going on here...
Spacecookies

EDIT: I'm using 1.0 Beta 5


Top
 Profile  
Reply with quote  
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 1 post ] 

All times are UTC + 1 hour


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Group