Horde3D

Next-Generation Graphics Engine
It is currently 18.10.2021, 05:16

All times are UTC + 1 hour




Post new topic Reply to topic  [ 8 posts ] 
Author Message
PostPosted: 12.10.2013, 02:54 
Offline

Joined: 12.10.2013, 02:05
Posts: 5
first, HI

I got the git version today, I compil, install. Then I tried to run a sample, but it failed. I give you all commands I used and all outputs I got :
Code:
[user@motorhead gits]$ git clone https://github.com/horde3d/Horde3D
Clonage dans 'Horde3D'
remote: Counting objects: 621, done.
remote: Compressing objects: 100% (396/396), done.
remote: Total 621 (delta 231), reused 586 (delta 202)
Receiving objects: 100% (621/621), 6.60 MiB | 5.70 MiB/s, done.
Resolving deltas: 100% (231/231), done.
Checking connectivity... done


[user@motorhead gits]$ cd Horde3D/


[user@motorhead Horde3D]$ cmake .
-- The C compiler identification is GNU 4.8.1
-- The CXX compiler identification is GNU 4.8.1
-- Check for working C compiler: /usr/bin/cc
-- Check for working C compiler: /usr/bin/cc -- works
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
-- Check for working CXX compiler: /usr/bin/c++
-- Check for working CXX compiler: /usr/bin/c++ -- works
-- Detecting CXX compiler ABI info
-- Detecting CXX compiler ABI info - done
-- Looking for strncpy_s
-- Looking for strncpy_s - not found
-- Looking for XOpenDisplay in /usr/lib/libX11.so;/usr/lib/libXext.so
-- Looking for XOpenDisplay in /usr/lib/libX11.so;/usr/lib/libXext.so - found
-- Looking for gethostbyname
-- Looking for gethostbyname - found
-- Looking for connect
-- Looking for connect - found
-- Looking for remove
-- Looking for remove - found
-- Looking for shmat
-- Looking for shmat - found
-- Looking for IceConnectionNumber in ICE
-- Looking for IceConnectionNumber in ICE - found
-- Found X11: /usr/lib/libX11.so
-- Found OpenGL: /usr/lib/libGL.so 
-- Looking for glXGetProcAddressARB
-- Looking for glXGetProcAddressARB - found
-- Configuring done
-- Generating done
-- Build files have been written to: /home/user/Projects/gits/Horde3D


[user@motorhead Horde3D]$ make
Scanning dependencies of target Horde3DTerrain
[  1%] Building CXX object Extensions/Terrain/Source/CMakeFiles/Horde3DTerrain.dir/extension.o
[  3%] Building CXX object Extensions/Terrain/Source/CMakeFiles/Horde3DTerrain.dir/terrain.o
Linking CXX static library libHorde3DTerrain.a
[  3%] Built target Horde3DTerrain
Scanning dependencies of target glfw
[  5%] Building C object Horde3D/Samples/glfw/CMakeFiles/glfw.dir/lib/enable.o
[  6%] Building C object Horde3D/Samples/glfw/CMakeFiles/glfw.dir/lib/fullscreen.o
[  8%] Building C object Horde3D/Samples/glfw/CMakeFiles/glfw.dir/lib/glext.o
[ 10%] Building C object Horde3D/Samples/glfw/CMakeFiles/glfw.dir/lib/image.o
[ 11%] Building C object Horde3D/Samples/glfw/CMakeFiles/glfw.dir/lib/init.o
[ 13%] Building C object Horde3D/Samples/glfw/CMakeFiles/glfw.dir/lib/input.o
[ 15%] Building C object Horde3D/Samples/glfw/CMakeFiles/glfw.dir/lib/joystick.o
[ 16%] Building C object Horde3D/Samples/glfw/CMakeFiles/glfw.dir/lib/stream.o
[ 18%] Building C object Horde3D/Samples/glfw/CMakeFiles/glfw.dir/lib/tga.o
[ 20%] Building C object Horde3D/Samples/glfw/CMakeFiles/glfw.dir/lib/thread.o
[ 22%] Building C object Horde3D/Samples/glfw/CMakeFiles/glfw.dir/lib/time.o
[ 23%] Building C object Horde3D/Samples/glfw/CMakeFiles/glfw.dir/lib/window.o
[ 25%] Building C object Horde3D/Samples/glfw/CMakeFiles/glfw.dir/lib/x11/x11_enable.o
[ 27%] Building C object Horde3D/Samples/glfw/CMakeFiles/glfw.dir/lib/x11/x11_fullscreen.o
[ 28%] Building C object Horde3D/Samples/glfw/CMakeFiles/glfw.dir/lib/x11/x11_glext.o
[ 30%] Building C object Horde3D/Samples/glfw/CMakeFiles/glfw.dir/lib/x11/x11_init.o
[ 32%] Building C object Horde3D/Samples/glfw/CMakeFiles/glfw.dir/lib/x11/x11_joystick.o
[ 33%] Building C object Horde3D/Samples/glfw/CMakeFiles/glfw.dir/lib/x11/x11_keysym2unicode.o
[ 35%] Building C object Horde3D/Samples/glfw/CMakeFiles/glfw.dir/lib/x11/x11_thread.o
[ 37%] Building C object Horde3D/Samples/glfw/CMakeFiles/glfw.dir/lib/x11/x11_time.o
[ 38%] Building C object Horde3D/Samples/glfw/CMakeFiles/glfw.dir/lib/x11/x11_window.o
/home/user/Projects/gits/Horde3D/Horde3D/Samples/glfw/lib/x11/x11_window.c: In function ‘translateKey’:
/home/user/Projects/gits/Horde3D/Horde3D/Samples/glfw/lib/x11/x11_window.c:227:5: attention : ‘XKeycodeToKeysym’ is deprecated (declared at /usr/include/X11/Xlib.h:1699) [-Wdeprecated-declarations]
     key = XKeycodeToKeysym( _glfwLibrary.display, keycode, 1 );
     ^
/home/user/Projects/gits/Horde3D/Horde3D/Samples/glfw/lib/x11/x11_window.c:249:5: attention : ‘XKeycodeToKeysym’ is deprecated (declared at /usr/include/X11/Xlib.h:1699) [-Wdeprecated-declarations]
     key = XKeycodeToKeysym( _glfwLibrary.display, keycode, 0 );
     ^
Linking C static library libglfw.a
[ 38%] Built target glfw
Scanning dependencies of target Horde3D
[ 40%] Building CXX object Horde3D/Source/Horde3DEngine/CMakeFiles/Horde3D.dir/egAnimatables.o
[ 42%] Building CXX object Horde3D/Source/Horde3DEngine/CMakeFiles/Horde3D.dir/egAnimation.o
[ 44%] Building CXX object Horde3D/Source/Horde3DEngine/CMakeFiles/Horde3D.dir/egCamera.o
[ 45%] Building CXX object Horde3D/Source/Horde3DEngine/CMakeFiles/Horde3D.dir/egCom.o
[ 47%] Building CXX object Horde3D/Source/Horde3DEngine/CMakeFiles/Horde3D.dir/egExtensions.o
[ 49%] Building CXX object Horde3D/Source/Horde3DEngine/CMakeFiles/Horde3D.dir/egGeometry.o
[ 50%] Building CXX object Horde3D/Source/Horde3DEngine/CMakeFiles/Horde3D.dir/egLight.o
[ 52%] Building CXX object Horde3D/Source/Horde3DEngine/CMakeFiles/Horde3D.dir/egMain.o
[ 54%] Building CXX object Horde3D/Source/Horde3DEngine/CMakeFiles/Horde3D.dir/egMaterial.o
[ 55%] Building CXX object Horde3D/Source/Horde3DEngine/CMakeFiles/Horde3D.dir/egModel.o
[ 57%] Building CXX object Horde3D/Source/Horde3DEngine/CMakeFiles/Horde3D.dir/egModules.o
[ 59%] Building CXX object Horde3D/Source/Horde3DEngine/CMakeFiles/Horde3D.dir/egParticle.o
[ 61%] Building CXX object Horde3D/Source/Horde3DEngine/CMakeFiles/Horde3D.dir/egPipeline.o
[ 62%] Building CXX object Horde3D/Source/Horde3DEngine/CMakeFiles/Horde3D.dir/egPrimitives.o
[ 64%] Building CXX object Horde3D/Source/Horde3DEngine/CMakeFiles/Horde3D.dir/egRendererBase.o
[ 66%] Building CXX object Horde3D/Source/Horde3DEngine/CMakeFiles/Horde3D.dir/egRenderer.o
[ 67%] Building CXX object Horde3D/Source/Horde3DEngine/CMakeFiles/Horde3D.dir/egResource.o
[ 69%] Building CXX object Horde3D/Source/Horde3DEngine/CMakeFiles/Horde3D.dir/egScene.o
[ 71%] Building CXX object Horde3D/Source/Horde3DEngine/CMakeFiles/Horde3D.dir/egSceneGraphRes.o
[ 72%] Building CXX object Horde3D/Source/Horde3DEngine/CMakeFiles/Horde3D.dir/egShader.o
[ 74%] Building CXX object Horde3D/Source/Horde3DEngine/CMakeFiles/Horde3D.dir/egTexture.o
[ 76%] Building CXX object Horde3D/Source/Horde3DEngine/CMakeFiles/Horde3D.dir/utImage.o
[ 77%] Building CXX object Horde3D/Source/Horde3DEngine/CMakeFiles/Horde3D.dir/utOpenGL.o
Linking CXX shared library libHorde3D.so
[ 77%] Built target Horde3D
Scanning dependencies of target Horde3DUtils
[ 79%] Building CXX object Horde3D/Source/Horde3DUtils/CMakeFiles/Horde3DUtils.dir/main.o
Linking CXX shared library libHorde3DUtils.so
[ 79%] Built target Horde3DUtils
Scanning dependencies of target Terrain
[ 81%] Building CXX object Extensions/Terrain/Sample/CMakeFiles/Terrain.dir/app.o
[ 83%] Building CXX object Extensions/Terrain/Sample/CMakeFiles/Terrain.dir/main.o
Linking CXX executable Terrain
[ 83%] Built target Terrain
Scanning dependencies of target ColladaConv
[ 84%] Building CXX object Horde3D/Source/ColladaConverter/CMakeFiles/ColladaConv.dir/converter.o
[ 86%] Building CXX object Horde3D/Source/ColladaConverter/CMakeFiles/ColladaConv.dir/daeMain.o
[ 88%] Building CXX object Horde3D/Source/ColladaConverter/CMakeFiles/ColladaConv.dir/main.o
[ 89%] Building CXX object Horde3D/Source/ColladaConverter/CMakeFiles/ColladaConv.dir/optimizer.o
[ 91%] Building CXX object Horde3D/Source/ColladaConverter/CMakeFiles/ColladaConv.dir/utils.o
Linking CXX executable ../../Binaries/Linux/ColladaConv
[ 91%] Built target ColladaConv
Scanning dependencies of target Chicago
[ 93%] Building CXX object Horde3D/Samples/Chicago/CMakeFiles/Chicago.dir/app.o
[ 94%] Building CXX object Horde3D/Samples/Chicago/CMakeFiles/Chicago.dir/crowd.o
[ 96%] Building CXX object Horde3D/Samples/Chicago/CMakeFiles/Chicago.dir/main.o
Linking CXX executable ../../Binaries/Linux/Chicago
[ 96%] Built target Chicago
Scanning dependencies of target Knight
[ 98%] Building CXX object Horde3D/Samples/Knight/CMakeFiles/Knight.dir/app.o
[100%] Building CXX object Horde3D/Samples/Knight/CMakeFiles/Knight.dir/main.o
Linking CXX executable ../../Binaries/Linux/Knight
[100%] Built target Knight


[user@motorhead Horde3D]$ su
Mot de passe : AngelaMerkelIsSoHot


[root@motorhead Horde3D]# make install
[  3%] Built target Horde3DTerrain
[ 38%] Built target glfw
[ 77%] Built target Horde3D
[ 79%] Built target Horde3DUtils
[ 83%] Built target Terrain
[ 91%] Built target ColladaConv
[ 96%] Built target Chicago
[100%] Built target Knight
Install the project...
-- Install configuration: ""
-- Installing: /usr/local/include/horde3d/Horde3DTerrain.h
-- Installing: /usr/local/lib/libHorde3D.so
-- Installing: /usr/local/lib/libHorde3DUtils.so
-- Removed runtime path from "/usr/local/lib/libHorde3DUtils.so"
-- Installing: /usr/local/include/horde3d/Horde3D.h
-- Installing: /usr/local/include/horde3d/Horde3DUtils.h


[root@motorhead Horde3D]# exit


[user@motorhead Horde3D]$ cd Horde3D/Binaries/Linux/


[user@motorhead Linux]$ ls
Chicago  ColladaConv  Knight


[user@motorhead Linux]$ ./Chicago
Unable to initalize engine
Make sure you have an OpenGL 2.0 compatible graphics card[user@motorhead Linux]$


[user@motorhead Linux]$ format c:\
take a drink my friend, this is not windows!

n.b. : adding a "\n" at the end of "Make sure you have an OpenGL 2.0 compatible graphics card" make it more sexy!


I also tried to compil some "small pieces of code" see at different places,
from here : http://www.horde3d.org/wiki/index.php5? ... ng_Horde3D
when I compil :
Code:
#include"glfw.h"
 #include"Horde3D.h"
 #include"Horde3DUtils.h"
 int main()
 {
   glfwInit();
   if(!glfwOpenWindow(640,480,8,8,8,8,24,8,GLFW_WINDOW))
   {
       glfwTerminate();
       return 1;
   }
   h3dInit();
   h3dRelease();
   glfwCloseWindow();
   glfwTerminate();
 }

I got several troubles,
- first the include are with "" instead of <> I think...

- second I don't have glfw.h installed on my system, I think when I do the make install, it doesn't install files related to glfw. Even if I set the path to glfw.h to the one downloaded by git (...)/Horde3D/Horde3D/Samples/glfw/glfw.h I got a link error : main.cc:(.text+0x70): référence indéfinie vers « h3dutLoadResource (in english undefined reference...)

- third : still on that page you gave the line command to compil :
Code:
gcc -o app main.cpp -lGL -lHorde3D

sound odd, because gcc is for C and g++ is for C++...

- fourth, <Horde3D.h> and <Horde3DUtils.h> in the way to be included properly need <horde3d/Horde3D.h> and <horde3d/Horde3DUtils.h>

I wasn't able to compile the code from http://www.horde3d.org/docs/html/_tutorial.html , we should first focus on the code above.

the computer I'm using is old, very old... the video card is an XPRESS 220M, but (!) Opengl is working...


« nothing epic in short post » :mrgreen:


Last edited by BrainlessMutant on 13.10.2013, 18:02, edited 1 time in total.

Top
 Profile  
Reply with quote  
PostPosted: 13.10.2013, 03:24 
Offline

Joined: 30.09.2010, 03:06
Posts: 21
I don't know if XPRESS 220M is >= Opengl 2.0

But you are able to compile and link the samples, what you are not able is to run them.

If it failed in compilation or linking you will not get up to 100% and these messages

[*]Built target Horde3DTerrain
[*]Built target glfw
[*]Built target Horde3D
[*]Built target Horde3DUtils
[*]Built target Terrain
[*]Built target ColladaConv
[*]Built target Chicago
[*]Built target Knight


For run the samples, I think you don't need to su, you can go to the folder and run them directly (they only need to find the resources like models and so on).

try to know your OpenGL version, in a sample without horde3d (only glfw) write that line http://stackoverflow.com/a/7909595/682603 something on the lines of

Code:
#include"glfw.h"
int main()
{
   glfwInit();
   if(!glfwOpenWindow(640,480,8,8,8,8,24,8,GLFW_WINDOW))
   {
       glfwTerminate();
       return 1;
   }
   printf("%s\n", glGetString(GL_VERSION));
   glfwCloseWindow();
   glfwTerminate();
}


As for the undefined reference, probably

Code:
ldconfig -v | grep "*3d*"
or
ldconfig -p | grep "*3d*"


if you can't find it here, it means ld is not finding it... so you have 2 options IIRC add it on the system wide search path... don't remember something like /etc/ld.conf... or when invoking gcc or g++ add

Code:
-L/usr/local/lib/


I will also recommend "copy and paste" Knight in another directory at same level and change it accordingly... to have a basic setup... also you will need to modify the CMakeLists.txt one level up in directory hierarchy to add your new "sample"... so you could compile and link it from start via cmake and the "used environment setup for samples".


Top
 Profile  
Reply with quote  
PostPosted: 13.10.2013, 07:12 
Offline

Joined: 12.10.2013, 02:05
Posts: 5
about the undefined reference, I felt confused, because there is a "glfw" directory in "horde3D"... and I also have "glfw-3.0.3-1" installed on my system...
I remove the installed "glfw-3.0.3-1" and compil this code :
Code:
#include<iostream>
#include"/home/user/Projects/gits/Horde3D/Horde3D/Samples/glfw/glfw.h"
int main()
{
   glfwInit();
   if(!glfwOpenWindow(640,480,8,8,8,8,24,8,GLFW_WINDOW))
   {
       glfwTerminate();
       return 1;
   }
   std::cout << glGetString(GL_VERSION) << std::endl;
   glfwCloseWindow();
   glfwTerminate();
}

by :
Code:
g++ -o app main.cc
-L/home/user/Projects/gits/Horde3D/Horde3D/Samples/glfw/ -lGL -lglfw
-lX11

and get :
Code:
2.1 Mesa 9.2.1

tyoc213 wrote:
For run the samples, I think you don't need to su, you can go to the folder and run them directly (they only need to find the resources like models and so on).

I wasn't in su, when it failed I asked myself if there is a problem with the model. I have to recognize I didn't check because I was tired and because when I run the sample I didn't get a message like "dude, I can't find the model..." I check in the source code (Chicago/app.cpp) for me it's look fine, it should find the model (but, I can still have wrong...). I got the git again, compiled, installed and failed running the sample again...


Top
 Profile  
Reply with quote  
PostPosted: 13.10.2013, 07:48 
Offline

Joined: 30.09.2010, 03:06
Posts: 21
You can search in the code you are trying to run: "Unable to initalize engine" without quotes.

It is the code executed on

Code:
std::cout << "Unable to initalize engine" << std::endl;


Most probably app->init() is returning false... so for this momment I suggest look at the specific bool Application::init() code and write a trace there... something on the lines of cout << "step 0" << endl; but it looks that only fails if h3dInit() is false and return calling before h3dutDumpMessages() which write an html file Horde3D_Log.html probably you have one like that.

Lets see?


Top
 Profile  
Reply with quote  
PostPosted: 13.10.2013, 17:59 
Offline

Joined: 12.10.2013, 02:05
Posts: 5
well... I didn't see the log..., so let's take a look :
Code:
Horde3D Log
Horde3D 1.0.0 Beta5
0.011    

Initializing GL2 backend using OpenGL driver '2.1 Mesa 9.2.1' by 'X.Org R300 Project' on 'Gallium 0.4 on ATI RS480'

0.011    

Extension EXT_texture_compression_s3tc not supported

0.011    

Failed to init renderer backend, debug info following

0.011    

Supported extensions: 'GL_ARB_multisample GL_EXT_abgr GL_EXT_bgra GL_EXT_blend_color GL_EXT_blend_minmax GL_EXT_blend_subtract GL_EXT_copy_texture GL_EXT_polygon_offset GL_EXT_subtexture GL_EXT_texture_object GL_EXT_vertex_array GL_EXT_compiled_vertex_array GL_EXT_texture GL_EXT_texture3D GL_IBM_rasterpos_clip GL_ARB_point_parameters GL_EXT_draw_range_elements GL_EXT_packed_pixels GL_EXT_point_parameters GL_EXT_rescale_normal GL_EXT_separate_specular_color GL_EXT_texture_edge_clamp GL_SGIS_generate_mipmap GL_SGIS_texture_border_clamp GL_SGIS_texture_edge_clamp GL_SGIS_texture_lod GL_ARB_multitexture GL_IBM_multimode_draw_arrays GL_IBM_texture_mirrored_repeat GL_ARB_texture_cube_map GL_ARB_texture_env_add GL_ARB_transpose_matrix GL_EXT_blend_func_separate GL_EXT_fog_coord GL_EXT_multi_draw_arrays GL_EXT_secondary_color GL_EXT_texture_env_add GL_EXT_texture_filter_anisotropic GL_EXT_texture_lod_bias GL_INGR_blend_func_separate GL_NV_blend_square GL_NV_light_max_exponent GL_NV_texgen_reflection GL_NV_texture_env_combine4 GL_SUN_multi_draw_arrays GL_ARB_texture_border_clamp GL_ARB_texture_compression GL_EXT_framebuffer_object GL_EXT_texture_env_combine GL_EXT_texture_env_dot3 GL_MESA_window_pos GL_NV_packed_depth_stencil GL_NV_texture_rectangle GL_ARB_depth_texture GL_ARB_occlusion_query GL_ARB_shadow GL_ARB_texture_env_combine GL_ARB_texture_env_crossbar GL_ARB_texture_env_dot3 GL_ARB_texture_mirrored_repeat GL_ARB_window_pos GL_EXT_stencil_two_side GL_EXT_texture_cube_map GL_NV_fog_distance GL_APPLE_packed_pixels GL_APPLE_vertex_array_object GL_ARB_draw_buffers GL_ARB_fragment_program GL_ARB_fragment_shader GL_ARB_shader_objects GL_ARB_vertex_program GL_ARB_vertex_shader GL_ATI_draw_buffers GL_ATI_texture_env_combine3 GL_ATI_texture_float GL_EXT_shadow_funcs GL_EXT_stencil_wrap GL_MESA_pack_invert GL_MESA_ycbcr_texture GL_NV_primitive_restart GL_ARB_fragment_program_shadow GL_ARB_half_float_pixel GL_ARB_occlusion_query2 GL_ARB_point_sprite GL_ARB_shading_language_100 GL_ARB_sync GL_ARB_texture_non_power_of_two GL_


ok there is a problem :
Code:
Extension EXT_texture_compression_s3tc not supported


to solve this, I create ~/.drirc :
Code:
<driconf>
   <device screen="0" >
      <application name="all">
          <option name="force_s3tc_enable" value="true" />
      </application>
   </device>
</driconf>

the sample is running, not completly properly, the reason is clearly because the computer is old, and for what I need to do, it should be enough. I'll try and will see...

thx tyoc213, I consider this question solved


Top
 Profile  
Reply with quote  
PostPosted: 15.10.2013, 05:49 
Offline

Joined: 21.08.2008, 11:44
Posts: 354
May be you need to install libtxc_dxtn? S3 texture compression extension is not installed with open source drivers by default.


Top
 Profile  
Reply with quote  
PostPosted: 16.10.2013, 00:53 
Offline

Joined: 12.10.2013, 02:05
Posts: 5
Siavash wrote:
May be you need to install libtxc_dxtn? S3 texture compression extension is not installed with open source drivers by default.

thx for the tips. Anyway I still have some problems. I add an attachment just to showing you what's going wrong when I'm starting the knight sample. Here the console output :
Code:
[user@motorhead Linux]$ ./Knight
r300 FP: Compiler Error:
compiler/r300_fragprog_emit.c::begin_tex(): Too many texture indirections
Using a dummy shader instead.
r300 FP: Compiler Error:
compiler/r300_fragprog_emit.c::begin_tex(): Too many texture indirections
Using a dummy shader instead.
r300 FP: Compiler Error:
compiler/r300_fragprog_emit.c::emit_alu(): Too many ALU instructions
Using a dummy shader instead.
r300 FP: Compiler Error:
compiler/r300_fragprog_emit.c::emit_alu(): Too many ALU instructions
Using a dummy shader instead.

when I start Chicago, (with less walkers for not blowing the ram...), walkers are textured, I also have the skybox, but the ground is black.

I guess this isn't bug, this sound more because the age of my computer. But, I want to notice I never see such "glitches" with Ogre3D.


Attachments:
2013-10-15-144341_1280x800_scrot.png
2013-10-15-144341_1280x800_scrot.png [ 65.92 KiB | Viewed 11588 times ]
Top
 Profile  
Reply with quote  
PostPosted: 16.10.2013, 04:45 
Offline

Joined: 21.08.2008, 11:44
Posts: 354
Hmm, Ogre3D is probably using a Forward renderer by default for their examples, whereas Horde3D is using a Deferred renderer and HDR pipeline for bundled samples by default.

After running Horde3D samples try pressing F3 key to switch between Deferred/HDR and Forward rendering pipelines to see if they start rendering correctly. If that worked for you that means your card or driver has issues with floating point texture buffers and texture lookups.

From this point you might contact radeon driver developers at #radeon or their mailing lists to discuss this issue to see if there is a chance to fix it from driver side.


Top
 Profile  
Reply with quote  
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 8 posts ] 

All times are UTC + 1 hour


Who is online

Users browsing this forum: No registered users and 4 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Group